Sending UDP 7411 traffic to local nics

2 posts / 0 new
Last post
Offline
Last seen: 2 years 1 month ago
Joined: 06/25/2018
Posts: 1
Sending UDP 7411 traffic to local nics

I have 2 computers running DDS configure to use unicast mode 

Computer 1 has 4 interfaces:

 

eth0 (10.20.30.10)

eth1 (169.254.0.1)

eth2(169.254.0.5 )

eth3 (192.168.168.1)

 

Computer 2 has 1 interface:

eth0 (10.20.30.20)

 

The Unicast is configured between 10.20.30.10 and 10.20.30.20 like this in the USER_QOS_PROFILES:

 

 <discovery>
          <initial_peers>
           
          <element>builtin.udpv4://10.20.30.10</element><element>builtin.udpv4://10.20.30.20</element></initial_peers>
          <multicast_receive_addresses/>
        </discovery>

 <property>
          <value>
            <!-- That value should be always set to 1. Because it has lower priority
                 than multicast and will affect nothing if multicast enabled -->
            <element>
              <name>dds.transport.UDPv4.builtin.unicast_enabled</name>
              <value>1</value>
            </element>
            <!-- Set value to "0" when wish to switch to Unicast -->
            <element>
              <name>dds.transport.UDPv4.builtin.multicast_enabled</name>
              <value>0</value>
            </element>
            <element>
              <name>dds.transport.UDPv4.builtin.multicast_ttl</name>
              <value>5</value>
            </element>
         </value>
        </property>
 
 
When I've checked my network equipment I discovered that the 10.20.30.20 machine sends millions of udp packets to the addresses belongs to the eth1,eth2, eht3 on the seond computer. 
These address arn't rountable, and aren't reachable - so obviesly nothing happenes, just a network overload of junk. 
 
How can I disable this behaviour ? 
 
Thanks, 
Dani
 
     

 

 

 

sara's picture
Offline
Last seen: 23 hours 40 min ago
Joined: 01/16/2013
Posts: 125

Hi Dani,

Have you tried to deny at DDS level the interfaces you do not want to use? You can see how in this article: https://community.rti.com/howto/configure-dds-work-multiple-network-interfaces

Let me know if that works,
Sara