Is rticonnextdds-connector compatible with DDS Secure?

3 posts / 0 new
Last post
Offline
Last seen: 1 month 5 days ago
Joined: 05/28/2020
Posts: 4
Is rticonnextdds-connector compatible with DDS Secure?

Question as titled.  Are the rticonnextdds-connector libraries for python/js/etc compatible with a system using DDS Secure?

Offline
Last seen: 1 month 3 days ago
Joined: 10/22/2018
Posts: 59

Hi,

Unfortunately, Connector cannot currently load the DDS Security Plugins since it does not have the capability to load dynamically linked libraries.

This is documented here: https://community.rti.com/static/documentation/connector/1.0.0/api/python/features.html#general-features

Sam

Offline
Last seen: 1 month 5 days ago
Joined: 05/28/2020
Posts: 4

Do you know if this feature is on the planned roadmap?  Would love to use this tool, but see this as a future blocker.