Persistence Service loading NDDS_QOS_PROFILES

2 posts / 0 new
Last post
Offline
Last seen: 2 years 6 months ago
Joined: 04/28/2013
Posts: 38
Persistence Service loading NDDS_QOS_PROFILES

Hello,

I'm having a bit of a problem with the persistence configuration, in that it doesn't find the profile specified in a property (on version 5.0.0)

I'm running the persistence service with the default persistence configuration and NDDS_QOS_PROFILES is set to an examle QoS ($NDDSHOME/resource/qos_profiles_5.0.0/xml/NDDS_QOS_PROFILES.example.xml)

The command is:

"$(NDDSHOME)/scripts/rtipersistenceservice.bat" -pauseAtEnd -cfgName defaultDisk

The only thing I've changed is adding the following in the default persistence qos:

 

<participant_qos>

   <property>

     <value>

           <element>

                 <name>rti.monitor.library</name>

                 <value>rtimonitoring</value>

          </element>

           <element>

                   <name>rti.monitor.config.qos_library</name>

                   <value>NddsQosProfilesLibrary</value>

           </element>

           <element>          

                   <name>rti.monitor.config.qos_profile</name>

                   <value>DefaultProfile</value>

            </element>

     </value>

     </property>

</participant_qos>

 

 

 

I get an error "profile NddsQosProfilesLibrary::DefaultProfile not found"

I tried the same thing on 4.5f and everything seemed to work. Were there any changes to that functionality on 5.0.0?

Thanks,

Michael

bobby's picture
Offline
Last seen: 1 year 1 month ago
Joined: 07/25/2011
Posts: 20

Hi Michael,

Thank you for submitting your question on our community portal. Since you also submitted your question to our support team and it was answered through that channel, I wanted to follow up here.

The issue you encountered will be fixed in our next release. 

Regards,

Bobby