Ignore Specific Ip in discovery network

5 posts / 0 new
Last post
Offline
Last seen: 2 months 5 days ago
Joined: 09/10/2022
Posts: 6
Ignore Specific Ip in discovery network

Hi,

How can ignore specific Ip in the discovery network???

Howard's picture
Offline
Last seen: 11 hours 28 min ago
Joined: 11/29/2012
Posts: 448

Can you clarify what you're asking about?

Do you want a Participant to restrict what interfaces it uses on the local host?

Or do you want a participant to reject the discovery of any participants that have addresses on a specific network?

Or something else?

Offline
Last seen: 2 months 5 days ago
Joined: 09/10/2022
Posts: 6

Hi Howard
Thanks for answering...

I want to disable specific addresses in the Discovery network in DDS, which means for example 192.168.88.* addresses don't discover via rti.
I set this connection interface for another job and I don't want it to be discovered via RTI

In My design :
I have 2 Pcs, I set Network with 10.10.10.1 and 10.10.10.2 for RTI
I set 10.10.10.1 on the one PC and set 10.10.10.2 on the other one. these Ips discovered by RTI and Transfer data together

After that I set another range Ip in connection lan2, 192.168.88.1 and 192.168.88.2, These addresses are reserved for another job and now these ports don't connect to any PCs. When I turn on My Pcs; I found that perhaps RTI retries to discover 192.168.88.* and transferring data in 10.10.10.* have been a lot of delays. when I connect ports of PCs by the Lan wire together, every thing are ok and I don't any delay

At the first I use {"dds.transport.UDPv4.builtin.parent.deny_multicast_interfaces_list", "192.168.100.*"} in policy::Property of DomainParticipantQos , but I didn't get result.

I want to disable or ignore 192.168.88.* address network in discovery cycle rti.

Thanks

Offline
Last seen: 2 months 5 days ago
Joined: 09/10/2022
Posts: 6

Hi
I found the solution it
add "dds.transport.UDPv4.builtin.parent.deny_interfaces_list", "eth3" instead of Ip address in Policy

Howard's picture
Offline
Last seen: 11 hours 28 min ago
Joined: 11/29/2012
Posts: 448

Great to hear that you figured out how to get it working!