Can not install RTI DDS Toolkit in cRio 9053

5 posts / 0 new
Last post
Offline
Last seen: 1 month 4 days ago
Joined: 07/01/2022
Posts: 3
Can not install RTI DDS Toolkit in cRio 9053

Hi, hope you can help me.

I have installed RTI DDS v 3.1.1.11 toolkit on my PC and it works fine publishing and subscribing data, so now, I want to do the same but in my cRio 9053, so the getting started document says that I should install the software by using NI Max; however, I can not find the RTI DDS toolkit in NI Max. Is there a compatibility problem? 

I am using Labview 2021SP1 32b, NI Linux RT image 21.5. I hope you can help me. Best regards.

Ismael Mendez's picture
Offline
Last seen: 1 week 4 days ago
Joined: 07/03/2017
Posts: 55

Hi Alex,

The cRIO-9053 uses an Intel x64 CPU. So it is compatible. You should see it in MAX->Remote Systems-><your cRIO-9053>->Add/Remove Software. Then choose "Custom Software Installation (currently installed)". After clicking "Next" in the menu should be "RTI DDS Toolkit 3.1.1".

If for some reason it's not there. You can install the toolkit manually by extracting the file data.tar that is compressed in file <National Instruments installation folder>\RT Images\RTI DDS Toolkit\<version>\x64intel\rti_dds.tar in the cRIO root folder. After extracting they should have the libraries in /usr/local/rti/lib and rtilvdds_libs.conf in /etc/ld.so.conf.d. Then restart the cRIO and the toolkit should be working.

Offline
Last seen: 1 month 4 days ago
Joined: 07/01/2022
Posts: 3

Hi, thanks for the reply.

I found the data.tar.gz file, so when I extract it there are three folders named "etc","home" and "usr". Could you tell me where should I copy those files? I am not sure if I should copy those files on:

C:\Program Files (x86)\National Instruments\CompactRIO  or C:\Program Files (x86)\National Instruments\RT Images\CompactRIO

Thanks for the support, best regards.

Ismael Mendez's picture
Offline
Last seen: 1 week 4 days ago
Joined: 07/03/2017
Posts: 55

Hi,

You should extract them in your cRIO root folder, not into your PC. You need to do the following:

Connect by ssh into your cRIO as admin (ssh [email protected]<your cRIO IP>).

It is possible that you need to enable remote access of your cRIO in MAX.

Copy the data.tar.gz from your PC into the cRIO (you can do it with the scp command)

Extract the data.tar.gz in the cRIO's root folder. This way content of the folders contained in data.ta.gz (etc, home, usr) will be placed in the right place.

Once extracted in your cRIO you should have the following files in your cRIO: 

/etc/ld.so.conf.d/rtidds_libs.conf

/home/lvuser/rti/RTI_DDS_Toolkit_License_Agreement.txt

/home/lvuser/rti/RTI_LABVIEW_CONFIG.documentationONLY.xml

/usr/local/natinst/labview/errors/English/rtidds.err

/usr/local/rti/lib/libnddsc.so

/usr/local/rti/lib/libnddssecurity.so

/usr/local/rti/lib/librtidlc.so

/usr/local/rti/lib/libnddscore.so

/usr/local/rti/lib/librtilvdds.so

/usr/local/rti/lib/librtimonitoring.so

Reboot the cRIO

Offline
Last seen: 1 month 4 days ago
Joined: 07/01/2022
Posts: 3

Thanks. It worked.